Tags: cmd, command, connect, database, error, exe, line, microsoft, mysql, oracle, publish, reports, rsexe, server, sql, utility

rs.exe utility : Could not connect to server...

On Database » Microsoft SQL Server

7,865 words with 4 Comments; publish: Sun, 01 Jun 2008 22:27:00 GMT; (250187.50, « »)

I'm trying to use rs.exe (used on command line cmd.exe) to publish my reports

and I get this error:

Could not connect to server:

http://myserver.com/reportserver/ReportService.asmx

When I access http://myserver.com/reportserver/ReportService.asmx with IE6,

I get an XML file displayed on the browser (I presume the content of

ReportService.asmx).

I type following command on cmd :

rs -i C:\myScripts\script.rss -u myUserName -p myPassword -s

http://myserver.com/reportServer -v parentFolder="TestPublishRSS1"

Any advice to make it work ?

Thanks

Macfly

All Comments

Leave a comment...

  • 4 Comments
    • I found the culprit, it was our McAfee virus scan which was blocking the

      rs.exe to connect. When I switched the rule off then the rs is working like a

      champ.

      Use>> rs -s <server> -i <inputfile> -t

      -T is the switch to trace. This would give more info on why it is not

      connecting.

      Check with the Firewall and Virus scan whether the rs.exe is been blocked.

      Hope this helps!.

      "MacFly" wrote:

      > No sorry, I'm still looking for a solution...

      >

      > "JDS" wrote:

      > > I am also getting same error but this used to work with the CTP version.

      > >

      > > My error says

      > > "Could not connect to server:

      > > http://myserver.com/reportserver/ReportService2005.asmx".

      > >

      > > Please let me know, if this problem is resolved.

      > > Thanks,

      > >

      > >

      > > "MacFly" wrote:

      > >

      > > > I'm trying to use rs.exe (used on command line cmd.exe) to publish my reports

      > > > and I get this error:

      > > > Could not connect to server:

      > > > http://myserver.com/reportserver/ReportService.asmx

      > > >

      > > > When I access http://myserver.com/reportserver/ReportService.asmx with IE6,

      > > > I get an XML file displayed on the browser (I presume the content of

      > > > ReportService.asmx).

      > > >

      > > > I type following command on cmd :

      > > > rs -i C:\myScripts\script.rss -u myUserName -p myPassword -s

      > > > http://myserver.com/reportServer -v parentFolder="TestPublishRSS1"

      > > >

      > > > Any advice to make it work ?

      > > > Thanks

      > > >

      > > > Macfly

      #3; Sun, 01 Jun 2008 22:30:00 GMT
    • Thanks a lot for this advice, I will try it as soon as possible !

      Macfly

      "JDS" wrote:

      > I found the culprit, it was our McAfee virus scan which was blocking the

      > rs.exe to connect. When I switched the rule off then the rs is working like a

      > champ.

      > Use>> rs -s <server> -i <inputfile> -t

      > -T is the switch to trace. This would give more info on why it is not

      > connecting.

      > Check with the Firewall and Virus scan whether the rs.exe is been blocked.

      > Hope this helps!.

      > "MacFly" wrote:

      > > No sorry, I'm still looking for a solution...

      > >

      > >

      > > "JDS" wrote:

      > >

      > > > I am also getting same error but this used to work with the CTP version.

      > > >

      > > > My error says

      > > > "Could not connect to server:

      > > > http://myserver.com/reportserver/ReportService2005.asmx".

      > > >

      > > > Please let me know, if this problem is resolved.

      > > > Thanks,

      > > >

      > > >

      > > > "MacFly" wrote:

      > > >

      > > > > I'm trying to use rs.exe (used on command line cmd.exe) to publish my reports

      > > > > and I get this error:

      > > > > Could not connect to server:

      > > > > http://myserver.com/reportserver/ReportService.asmx

      > > > >

      > > > > When I access http://myserver.com/reportserver/ReportService.asmx with IE6,

      > > > > I get an XML file displayed on the browser (I presume the content of

      > > > > ReportService.asmx).

      > > > >

      > > > > I type following command on cmd :

      > > > > rs -i C:\myScripts\script.rss -u myUserName -p myPassword -s

      > > > > http://myserver.com/reportServer -v parentFolder="TestPublishRSS1"

      > > > >

      > > > > Any advice to make it work ?

      > > > > Thanks

      > > > >

      > > > > Macfly

      #4; Sun, 01 Jun 2008 22:31:00 GMT